Back to overview
Degraded
Degraded performance
Mar 18, 2026 at 12:38pm UTC
Affected services
Website
Resolved
Mar 18, 2026 at 12:42pm UTC
Issue has been resolved and all users should experience the site as normal again now.
We will monitor this closely to make sure the solution is working as expected.
Affected services
Updated
Mar 18, 2026 at 12:39pm UTC
A fix has been deployed. The issue should be resolved in the next few minutes.
Affected services
Created
Mar 18, 2026 at 12:38pm UTC
We are receiving reports of degraded performance from some users that are inable to access the website due to issues with serving static assets from R2. We are working on a fix.
Affected services