Back to overview
Degraded

Premarket: Images temporarily unavailable & preview link bug resolved

Mar 23, 2026 at 11:16am UTC
Affected services
Website

Resolved
Mar 23, 2026 at 1:35pm UTC

All premarket images are now back up.

Updated
Mar 23, 2026 at 12:52pm UTC

Image are going back up again. Will will resolve the issue when all premarket homes have recovered fully.

Updated
Mar 23, 2026 at 12:07pm UTC

We are still working on the sync and getting the images back up again. Another update will be posted shortly.

Created
Mar 23, 2026 at 11:16am UTC

On Friday we released a new feature for Premarket listings that includes preview links. A small bug was discovered shortly after launch and has since been fixed. We are currently re-syncing all listings that are missing images, so affected listings will reappear shortly.