Back to overview
Downtime

Load Balancer Issue

Mar 31, 2026 at 10:10am UTC
Affected services
Website

Resolved
Mar 31, 2026 at 10:13am UTC

Traffic has been rerouted and we are online again.

Created
Mar 31, 2026 at 10:10am UTC

We are experiencing issues with our load balancer and are currently rerouting traffic.