Website is currently experiencing downtime
Resolved
May 28, 2026 at 2:06pm UTC
Website is back up now.
Affected services
Updated
May 28, 2026 at 2:05pm UTC
The restoration is now finally completed. We are bringing everything back online again.
Affected services
Updated
May 28, 2026 at 1:26pm UTC
We are currently performing a database restoration to a previous state. The service is temporarily unavailable during this process.
The restoration is estimated to be completed within approximately 120 minutes from the start time (2:08 PM CEST). We will update this page once the service is back online.
We apologize for any inconvenience.
Affected services
Updated
May 28, 2026 at 12:57pm UTC
Restoration is still in progress. We will inform you of any updates.
Affected services
Updated
May 28, 2026 at 12:39pm UTC
We have initiated a recovery process. Due to the amount of data being restored, this will unfortunately take some time. We estimate to be back online by 3.30pm and will keep you posted here meanwhile.
Affected services
Updated
May 28, 2026 at 12:23pm UTC
We have initiated a restoration process to bring all services back. It will likely take some time, but we will notify you again once it is completed.
Affected services
Created
May 28, 2026 at 12:13pm UTC
We have an incidents of homes and brokers not showing up on the site. We are working on the issue.
Affected services